Make ReIMG Image Resizer working with User Blog Mod on phpBB3 board

I came across this problem a couple nights ago, I had a phpBB3 board rel. 3.0.11 with User Blog Mod rel. 1.0.15 and Reimg Image Resizer rel. 2.0.1 https://www.phpbb.com/customise/db/mod/reimg_image_resizer/ . Googling I found a well done solution here https://www.phpbb.com/customise/db/mod/reimg_image_resizer/faq/f_700
So I found the template html page in subsilver2 (my default template) in charge of the page generation /WEBSITEROOT/styles/subsilver2/template/viewtopic_print.html and got the following code:


So i updated my /WEBSITEROOT/blog.php according to the above link instructions as follows (first 4 script lines):


Emptying cache and refreshing the big images have not got resized.

At this point I solved the problem in this way:

move into the template folder /WEBSITEROOT/styles/subsilver2/template/ edit the file attachment.html, the template file used by phpBB to format attachment html code, find the following code:


Replace with:


Now if you’re using subsilver2 or prosilver template check that the presence in overall_header.html right before the closing HEAD tag of this code:


or add it.
While if you’re using Coda or Blogger template (included in user blog mod) check the file /WEBSITEROOT/blog/styles/blogger(or coda)/blog/viewblog.html for the code above, if not present just add it right before the closing HEAD tag as shown above.
Check the presence in /WEBSITEROOT/blog.php of the LOAD_REIMG row in the very first rows:


or add it.
Empty cache and refresh.

It’s not fancy, you have to repeat this easy procedure for any template used, but it works!

Leave a Reply